Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Step 5 - Create Account (still unsolved please help)
#1
Exclamation 
hi!

I have installed THT for the 3rd time in total.

I tried 1.24, I tried reworked edition and today I tried 1.25.

All have the same problem with my setup:

Page 5 - Create Account:

The account is being created allright and I receive 3 emails (invoice, cpanel details and account created successfully).
However after the accounts have been created successfully (received email), page 5 is still locked (frozen) and nothing happens again.

Errorlog: PHP Fatal error: Call to a member function config() on a non-object in public_html/clients/index.php on line 14

CLOUDLINUX 5.9 x86_64 standard – red | Control Panel: WHM 11.34.1 (build 7) | THT Version: 1.25

I checked https://thehostingtool.com/forum/thread-1009.html but could find no fault in my settings / packages..

Thanks
Reply
#2
are u using the latest release version non forked?
Thanks for reading my post guys!
EddiesLife247 - YouTube Producer - THT Support Team
WEB: http://eddieslife247.co.uk/

Supporting TheHostingTool Community!

Need help, i don't mind pms but please post support questions in the general support board.
Reply
#3
(02-05-2013, 04:34 PM)TheBingsta Wrote: are u using the latest release version non forked?

Yes. 1.25.
Reply
#4
I was thinking this could have been an issue introduced in v1.2.5 but as it doesn't work for you in v1.2.4 either, I suppose it isn't. There isn't a reference to $db anywhere near line 14 of /clients/index.php What does that file contain for you? That error doesn't seem related to this issue.
Kevin Mark - TheHostingTool Lead Developer
Reply
#5
Hi, I just ran through it again and checked the error log, You are right, the error is not related.

What else can I try?


Thanks
Reply
#6
Clear your error log and try to capture the one which is causing this issue by going through the sign up process
Kevin Mark - TheHostingTool Lead Developer
Reply
#7
(02-06-2013, 03:11 PM)Kevin Wrote: Clear your error log and try to capture the one which is causing this issue by going through the sign up process


hi,
there is no error in the log... but with Firebug / NET tab I find this:

STATUS: ABORTED, recived 0 Bytes.

Request header:

GET /clients/includes/ajax.php?function=create&=sid:c1aebee4d8dc4db0d6a7220375165c64c1446814,1360178692&package=1&domain=dom&order1=Order&agree=true&username=wilma&password=123456&confirmp=123456&email=CORRECTEMAILADDRESSWASHERE&firstname=jkhjkhkhjk&lastname=jkhjkhjkh&address=jkhjkhhh&city=jkhjkhjkh&state=jkhjk&zip=07766&country=af&phone=06787567&human=abe7a&cdom=testtesttest.ll&csub=&back=Previous%20Step&next=Next%20Step HTTP/1.1
Host: CORRECTDOMAINWASHERE
User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:17.0) Gecko/20100101 Firefox/17.0
Accept: */*
Accept-Language: en-US,en;q=0.5
Accept-Encoding: gzip, deflate
Connection: keep-alive
X-Requested-With: XMLHttpRequest
Referer: http://CORRECTDOMAINWASHERE/clients/order/
Cookie: PHPSESSID=dcf7505206e5f14364506a897a742a86

Response body:

Reload the page to get source for: http://CORRECTDOMAINWASHERE/clients/includes/ajax.php?function=create&=sid:c1aebee4d8dc4db0d6a7220375165c64c1446814,1360178692&package=1&domain=dom&order1=Order&agree=true&username=wilma&password=123456&confirmp=123456&email=CORRECTEMAILADDRESSWASHERE&firstname=jkhjkhkhjk&lastname=jkhjkhjkh&address=jkhjkhhh&city=jkhjkhjkh&state=jkhjk&zip=07766&country=af&phone=06787567&human=abe7a&cdom=testtesttest.ll&csub=&back=Previous%20Step&next=Next%20Step

Parameters only:

=sid:c1aebee4d8dc4db0d6a7220375165c64c1446814,1360178692
address=jkhjkhhh
agree=true
back=Previous Step
cdom=testtesttest.ll
city=testing
confirmp=123456
country=af
csub=
domain=dom
email=CORRECTEMAILADDRESSWASHERE
firstname=jkhjkhkhjk
function=create
human=abe7a
lastname=jkhjkhjkh
next=Next Step
order1=Order
package=1
password=123456
phone=06787567
state=jkhjk
username=wilma
zip=07766


Thank you.
Reply
#8
in compiler.php change error_reporting to error_reporting(E_ALL); It looks like some kind of PHP error is stopping execution after creating the account so it never returns the success message.
Kevin Mark - TheHostingTool Lead Developer
Reply
#9
hi!

With error_reporting(E_ALL); I will see the following:

Notice: Undefined index: secret in public_html/clients/includes/csrf-magic.php on line 338

Notice: Use of undefined constant CRON - assumed 'CRON' in public_html/clients/includes/compiler.php on line 28

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at public_html/clients/includes/csrf-magic.php:338) in public_html/clients/includes/compiler.php on line 29

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at public_html/clients/includes/csrf-magic.php:338) in public_html/clients/includes/compiler.php on line 29

Notice: Undefined offset: 1 in public_html/clients/includes/compiler.php on line 67

Notice: Undefined offset: 1 in public_html/clients/includes/compiler.php on line 67

Notice: Undefined offset: 1 in public_html/clients/includes/compiler.php on line 67

Notice: Undefined offset: 1 in public_html/clients/includes/compiler.php on line 67

Notice: Undefined offset: 1 in public_html/clients/includes/compiler.php on line 67

Notice: Undefined offset: 1 in public_html/clients/includes/compiler.php on line 67

Notice: Undefined offset: 1 in public_html/clients/includes/compiler.php on line 67

Notice: Undefined offset: 1 in public_html/clients/includes/compiler.php on line 67

Notice: Undefined offset: 1 in public_html/clients/includes/compiler.php on line 67

Notice: Undefined offset: 1 in public_html/clients/includes/compiler.php on line 67

Notice: Undefined offset: 1 in public_html/clients/includes/compiler.php on line 67

Notice: Undefined offset: 1 in public_html/clients/includes/compiler.php on line 67

Notice: Undefined offset: 1 in public_html/clients/includes/compiler.php on line 67

Notice: Undefined index: HTTPS in public_html/clients/includes/compiler.php on line 114

Notice: Undefined index: HTTPS in public_html/clients/includes/compiler.php on line 118

Warning: Cannot modify header information - headers already sent by (output started at public_html/clients/includes/csrf-magic.php:338) in public_html/clients/includes/class_main.php on line 46


thanks
Reply
#10
Oops, sorry. Try error_reporting(E_ALL ^ E_NOTICE);
Kevin Mark - TheHostingTool Lead Developer
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)