Current time: 04-21-2014, 11:03 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Error on Step 5 [Kloxo with THT]
12-08-2011, 10:39 AM
Post: #11
RE: Error on Step 5 [Kloxo with THT]
(12-08-2011 10:01 AM)Liam D. Wrote:  Yes, will do.
(facepalm) I enabled display_errors on your server, and guess what:

Warning: curl_exec() has been disabled for security reasons in /home/hostramp.tk/hostumble.com/bill/includes/servers/kloxo.php on line 51

So, a big LOL for that on my part Tongue Please enable curl_exec via the Kloxo admin panel and everything will work out perfectly.

Thank you for the reply Smile

Well, i can't seem to find where to enable curl_exec. Is this done via PHP.ini ?
If you have kloxo access maybe you can point it out for me.

Thank you
Find all posts by this user
Quote this message in a reply
12-08-2011, 10:40 AM (This post was last modified: 12-08-2011 10:40 AM by Liam D..)
Post: #12
RE: Error on Step 5 [Kloxo with THT]
You need to Login to Kloxo as ADMIN (the username admin) and go to Domains -> <yourdomain> -> PHP Config -> Advanced PHP Config Tab -> disable_functions

Remove curl_exec, from the line (including the comma). Save it after.
Find all posts by this user
Quote this message in a reply
12-08-2011, 10:55 AM (This post was last modified: 12-09-2011 12:34 AM by DaReaper.)
Post: #13
RE: Error on Step 5 [Kloxo with THT]
Brilliant! Big Grin

I've managed to create an account now and i was not able to identify that having curl disabled for the domain caused it.

Thank you for spending your time in solving this for me Smile

[EDIT]

issue[FIXED] :

Code:
Warning: strftime() [function.strftime]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Asia/Calcutta' for 'IST/5.0/no DST' instead in /home/hostramp.tk/hostumble.com/bill/admin/pages/home.php on line 122

Edited PHP.ini for fixing the above issue and added :
Code:
;;;;;;;;;;;;;;;;;;;
; Module Settings ;
;;;;;;;;;;;;;;;;;;;

[Date]
date.timezone = CET ; set your own timezone here


Can you tell me how to fix these ? Thank you.
Find all posts by this user
Quote this message in a reply
12-09-2011, 03:28 AM
Post: #14
RE: Error on Step 5 [Kloxo with THT]
You need to edit the php.ini that is related to the account. Sometimes it may be in /home/<username>/kloxo/php.ini although I'm not sure. Login to SSH and run this:

Code:
find / -name php.ini

And edit the php.ini file that is related to your domain. Then restart Apache/LightTPD.
Find all posts by this user
Quote this message in a reply
12-10-2011, 03:15 AM
Post: #15
RE: Error on Step 5 [Kloxo with THT]
The strftime error is fixed as of r242.

Kevin Mark - TheHostingTool Lead Developer
Visit this user's website Find all posts by this user
Quote this message in a reply
12-10-2011, 11:08 AM
Post: #16
RE: Error on Step 5 [Kloxo with THT]
Thank you for that Liam. But i fixed the issue by adding the lines in my previous post into the PHP.ini Smile

(12-10-2011 03:15 AM)Kevin Wrote:  The strftime error is fixed as of r242.

Thank you for that kevin.

It says : To configure go
to General Settings -> General Configuration and then select your preferred
timezone from the dropdown menu.


But here's is what i have in General Settings -> General Configuration.

http://i.imgur.com/HkaiL.png

I don't know if i'm doing something wrong here.
Find all posts by this user
Quote this message in a reply
12-10-2011, 09:47 PM
Post: #17
RE: Error on Step 5 [Kloxo with THT]
I think that is included in the next version (1.2.4). Not sure though.
Find all posts by this user
Quote this message in a reply
12-11-2011, 03:33 AM
Post: #18
RE: Error on Step 5 [Kloxo with THT]
(12-10-2011 09:47 PM)Liam D. Wrote:  I think that is included in the next version (1.2.4). Not sure though.

Yes.

Kevin Mark - TheHostingTool Lead Developer
Visit this user's website Find all posts by this user
Quote this message in a reply
01-11-2012, 06:21 PM
Post: #19
RE: Error on Step 5 [Kloxo with THT]
(12-08-2011 10:40 AM)Liam D. Wrote:  You need to Login to Kloxo as ADMIN (the username admin) and go to Domains -> <yourdomain> -> PHP Config -> Advanced PHP Config Tab -> disable_functions

Remove curl_exec, from the line (including the comma). Save it after.

Hello Liam, i have follow your instructions until here and enabled the curl_exec and after this i have these errors...

Notice: Undefined variable: pagegen in "my-path"/tht/includes/variables.php on line 25

Notice: Undefined index: name in "my-path"/tht/includes/variables.php on line 72

Notice: Use of undefined constant PAGE - assumed 'PAGE' in "my-path"/tht/includes/variables.php on line 73

Notice: Undefined variable: navbits in "my-path"/tht/includes/variables.php on line 82

Notice: Undefined index: name in "my-path"/tht/includes/variables.php on line 72

Notice: Use of undefined constant PAGE - assumed 'PAGE' in "my-path"/tht/includes/variables.php on line 73

Notice: Undefined index: name in "my-path"/tht/includes/variables.php on line 72

Notice: Use of undefined constant PAGE - assumed 'PAGE' in "my-path"/tht/includes/variables.php on line 73

Notice: Undefined index: name in "my-path"/tht/includes/variables.php on line 72

Notice: Use of undefined constant PAGE - assumed 'PAGE' in "my-path"/tht/includes/variables.php on line 73

Notice: Use of undefined constant PAGE - assumed 'PAGE' in "my-path"/tht/includes/variables.php on line 91

Notice: Use of undefined constant SUB - assumed 'SUB' in "my-path"/tht/includes/variables.php on line 91

Notice: Undefined variable: html in "my-path"/tht/includes/class_style.php on line 86

Notice: Use of undefined constant INFO - assumed 'INFO' in "my-path"/tht/includes/variables.php on line 105
An error has occurred. Please inform your system administrator.

Can you help?
thanks
Find all posts by this user
Quote this message in a reply
01-11-2012, 10:47 PM
Post: #20
RE: Error on Step 5 [Kloxo with THT]
Odd, I never encountered that kind of error before. Please make a phpinfo() file and link me to it.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)