THT Community

Full Version: [NEW] xenForo/THT Forum Plugin
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Developer's Note

If you are using the old xenForo THT Plugin (http://thehostingtool.com/forum/thread-1573.html) then I would HIGHLY recommend you to switch to this one. The old one that I made has a security vulnerability that allows users to sign up even without password authentication (as reported by Jerry).

This version of the plugin is a MAJOR release, which fixes the issue. This is version 2.04 of the plugin.

Installation

Upload the zip file to your THT installation's root directory and unzip it, keeping the folder structure intact. It will replace old instances of the plugin if you have it installed. No other changes are necessary.

Changelog

Version 2.04-1 = Fixes an invalid MySQL return issue
Version 2.04 = Fixes a Major Security Issue with authentication.

Known Issues

Version 2.04 = I can't find a way to include a class file so I included the class XenForo_Authentication_Schema before opening class p2h. This will be fixed in future versions, although this is NOT that big of an issue.

I am also asking moderators to please DELETE the old plugin thread so that no one uses it anymore.

xenForo Versions

This has been tested with the latest version of xenForo (as of writing) -- v1.1.2. Although in theory, it may also work in xenForo's 1.0.x branch, although is NOT recommended. Versions in the 1.1.x branch older than 1.1.2 will also work.

THT Versions

This has been tested with the THT Community Edition (Naven's edition) although it WILL (99% probability) also work with the latest official release of THT (v1.2.3).

UPDATE: For support with this plugin, please go to http://www.thedevcafe.com/viewforum.php?f=23
(06-01-2012, 11:41 PM)Liam D. Wrote: [ -> ]I am also asking moderators to please DELETE the old plugin thread so that no one uses it anymore.

Hi there,
I deleted the thread myself. Smile
Can it compatible with XenForo 1.3.3 ?
It should work with 1.3.3, but I haven't tested it though. There were no significant changes to the way xenForo handles the database, so it could still work.